Talaia's integration with BGP allows our customers to reach new levels of visibility within their organizations. In order to do that, a few more configurations are required in your BGP router.

For those who are not very familiar with this configurations in Mikrotik, here is a list of the few steps needed to have the service up and running.

BGP is an standardized protocol used to exchange routing tables between entities known as Autonomous Systems on the internet.
There is 2 different ways to configure BGP, and it is up to the customer select which one to use:

  • iBGP: called iBGP, this protocol is used when it runs between two peers in the same Autonomous Systems.
  • eBGP: eBGP, for those cases when the peering is required between two different Autonomous Systems.

As mentioned before, Talaia support both protocols.

Mikrotik support BGP from version 4 or superior, and this guide will asume your BGP routing is already configured and properly working. 

Configure the peer

The first step, is configure your BGP Peer (in that case, Talaia's BGP router):

> /routing bgp peer add remote-address=<<TALAIA'S BGP IP>> remote-as=XXXXX

where "XXXX" is:

  • Your own Autonomous System for iBGP.
  • The ASN Talaia will provide you for eBGP.

The last, and most important configuration is to validate that those fields are both configured to "yes":

/routing bgp instance
set default client-to-client-reflection=yes

/routing bgp peer
set PEER NAME route-reflect=yes


Now, to validate everything is working properly, run 

> /routing bgp peer print status 

... and it's done!

if everything went as expected, you should see this field: 

state=established 

Trouble?

if the connection is not establish, you should ask your network administrator or Mikrotik support.

Did this answer your question?